CIDR address range | address range | Description | RFC |
0.0.0.0/8 | 0.0.0.0 to 0.255.255.255 | actual network (only valid as source address) | RFC 3232 (replaced RFC 1700) |
10.0.0.0/8 | 10.0.0.0 to 10.255.255.255 | Range for private use (in your LAN) | RFC 1918 |
100.64.0.0/10 | 100.64.0.0 to 100.127.255.255 | multiple used address space for provider-NAT | RFC 6598 |
127.0.0.0/8 | 127.0.0.0 to 127.255.255.255 | localnet | RFC 3330 |
169.254.0.0/16 | 169.254.0.0 to 169.254.255.255 | Zeroconf | RFC 3927 |
172.16.0.0/12 | 172.16.0.0 to 172.31.255.255 | Range for private use (in your LAN) | RFC 1918 |
192.0.0.0/24 | 192.0.0.0 to 192.0.0.255 | reserved for public use | |
192.0.2.0/24 | 192.0.2.0 to 192.0.2.255 | documentation and samplecode (TEST-NET-1) | RFC 5737 (replaced RFC 3330) |
192.88.99.0/24 | 192.88.99.0 to 192.88.99.255 | 6to4 Anycast (for redirecting) | RFC 3068 |
192.168.0.0/16 | 192.168.0.0 to 192.168.255.255 | Range for private use (in your LAN) | RFC 1918 |
198.18.0.0/15 | 198.18.0.0 to 198.19.255.255 | Network benchmark tests | RFC 2544 |
198.51.100.0/24 | 198.51.100.0 to 198.51.100.255 | documentation and samplecode (TEST-NET-2) | RFC 5737 |
203.0.113.0/24 | 203.0.113.0 to 203.0.113.255 | documentation and samplecode (TEST-NET-3) | RFC 5737 |
224.0.0.0/4 | 224.0.0.0 to 239.255.255.255 | Multicast Network (formerly class D network) | RFC 3171 |
240.0.0.0/4 | 240.0.0.0 to 255.255.255.255 | reserved (formerly class E network) | RFC 3232 (replaced RFC 1700) |
255.255.255.255 | 255.255.255.255 | Broadcast |
hpswitch> enable
password manager:
hpswitch# configure terminal
hpswitch(config)#
ciscoswitch> enable
enable password:
ciscoswitch# configure terminal
ciscoswitch(config)#
hpswitch(config)# vlan 5
hpswitch(vlan-5)# name "Sales_department"
hpswitch(vlan-5)# ip address 10.10.10.1 255.255.255.0
hpswitch(vlan-5)# untagged 1-22
hpswitch(vlan-5)# tagged 23-24
hpswitch(vlan-5)# exit
hpswitch(config)# write memory
ciscoswitch(config)# interface vlan 5
ciscoswitch(config-subif)# name "Sales_department"
ciscoswitch(config-subif)# ip address 10.10.10.1 255.255.255.0
ciscoswitch(config-subif)# exit
ciscoswitch(config)# interface gigabitethernet 1/0/1
ciscoswitch(config-if)# switchport mode access
ciscoswitch(config-if)# switchport access vlan 5
ciscoswitch(config-if)# exit
[repeat that for every interface which should be untagged member of that vlan]
[you can also define interface ranges interface range gigabitethernet 1/0/1 - 1/0/22]
ciscoswitch(config)# interface gigabitethernet 1/0/23
ciscoswitch(config-if)# switchport encapsulation dot1q
ciscoswitch(config-if)# switchport mode trunk
ciscoswitch(config-if)# switchport trunk allowed vlans 5
ciscoswitch(config-if)# exit
[repeat that for every interface which should be tagged member of that vlan]
[you can also define interface ranges interface range gigabitethernet 1/0/23 - 1/0/24]
ciscoswitch(config)# write memory
[on old devices this is copy running-config startup-config]
I have a few questions about vlans though, witch Cisco, what does "switchport access" do is it for tagging and trunk access?
And also on a vlan, do you need to config a default gateway since we're only dealing with switches? The no-ip thing is still unclear too, is it like a walled garden?
"switchport mode trunk" makes it a trunk port
To answer the question asked, 255.255.255.254::11111111.11111111.11111111.11100000::/27 ?this is nearly right :) The binary and the CIDR notation fits. But I think you have done a typing error in the decimal one.