hpswitch> enable
password manager:
hpswitch# configure terminal
hpswitch(config)# trunk 23,24 trk1 lacp
hpswitch(config)# write memory
ciscoswitch> enable
enable password:
ciscoswitch# configure terminal
ciscoswitch(config)# interface gigabitethernet 0/1
ciscoswitch(config-if)# channel-protocol lacp
ciscoswitch(config-if)# channel-group 1 mode active
ciscoswitch(config-if)# exit
ciscoswitch(config)# interface gigabitethernet 0/2
ciscoswitch(config-if)# channel-protocol lacp
ciscoswitch(config-if)# channel-group 1 mode active
ciscoswitch(config-if)# exit
ciscoswitch(config)# write memory
ciscoswitch#show etherchannel load-balance
EtherChannel Load-Balancing Configuration:
src-mac
EtherChannel Load-Balancing Addresses Used Per-Protocol:
Non-IP: Source MAC address
IPv4: Source MAC address
IPv6: Source MAC address
hpswitch(config)# spanning-tree
turn on spanning tree globally on the switchhpswitch(config)# spanning-tree force-version rstp-operation
set the protocol version to rapid spanning treehpswitch(config)# spanning-tree priority 1
set the priority for your switch. Every spanning tree instance needs a root bridge. the root bridge decides which links should be blocked. hpswitch(config)# spanning-tree 1-22 auto-edge-port
define access/edge ports as auto-edge-ports for not envolving them into the spanning tree topology. hpswitch(config)# no spanning-tree 23-24 auto-edge-port
set the uplinks port to no auto-edge-ports as they should be involved into the spanning tree topology.hpswitch(config)# spanning-tree 1-22 bpdu-protection
define a bpdu protection on the access/edge ports. If some plugs in a switch to one of theses ports the switch will not get a connect. ciscoswitch(config)# spanning-tree
turn on spanning tree globally on the switch -> is on by default ciscoswitch(config)# spanning-tree mode rapid-pvst
set the protocol version to rapid spanning tree ciscoswitch(config)# spanning-tree priority 1
set the priority for your switch. Every spanning tree instance needs a root bridge. the root bridge decides which links should be blocked. If you dont set the priorities accordingly ciscoswitch(config)# spanning-tree portfast default
set all ports to not be involved in the spanning tree topologyciscoswitch(config)# spanning-tree portfast bpduguard default
configure all ports with bdpuguard (bdpu protection)ciscoswitch(config)# interface gigabitethernet0/23
ciscoswitch(config-if)# spanning-tree portfast disable
ciscoswitch(config-if)# exit
switch to an uplink port to involve him to the spanning tree topology and to turn off bpdu Protection. Repeat that for all uplink ports. hpswitch(config)# spanning-tree
turn on spanning tree globally on the switch [code]hpswitch(config)# spanning-tree force-version mstp-operation
set the protocol version to multiple spanning tree -> which is used as defaulthpswitch(config)# spanning-tree config-name hp
hpswitch(config)# spanning-tree config-revision 1
Define an MST region identity for the switch. hpswitch(config)# spanning-tree instance 1 vlan 10 30
hpswitch(config)# spanning-tree instance 2 vlan 20 40
Associate user vlans with MSTP instances. If you have two instances you should consider using different root bridges for each instance. hpswitch1(config)# spanning-tree instance 1 priotity 1
hpswitch1(config)# spanning-tree instance 2 priotity 2
The configuration for the other root bridge may look like thishpswitch2(config)# spanning-tree instance 1 priority 2
hpswitch2(config)# spanning-tree instance 2 priority 1
Department | Subnet | VLAN | Switch IP User vlan | Switch IP Transfer Network |
DataCenter | 10.10.1.0/24 | 5 | 10.10.1.1 | 10.10.0.2 |
Sales | 10.10.2.0/24 | 10 | 10.10.2.1 | 10.10.0.3 |
Marketing | 10.10.3.0/24 | 15 | 10.10.3.1 | 10.10.0.4 |
dcswitch(config)# ip route 10.10.2.0 255.255.255.0 10.10.0.1
route to reach the sales departmentdcswitch(config)# ip route 10.10.3.0 255.255.255.0 10.10.0.1
route to reach the marketing departmentdcswitch(config)# ip default-gateway 10.10.0.1
salesswitch(config)# ip route 10.10.1.0 255.255.255.0 10.10.0.1
route to reach the datacentersalesswitch(config)# ip route 10.10.3.0 255.255.255.0 10.10.0.1
route to reach the marketing departmentsalesswitch(config)# ip default-gateway 10.10.0.1
can be used as alternative. This means that all traffic regarding subnets the switch doesn't know will be send to the router dcswitch(config)# ip route 10.10.1.0 255.255.255.0 10.10.0.1
route to reach the datacenterdcswitch(config)# ip route 10.10.2.0 255.255.255.0 10.10.0.1
route to reach the sales departmentdcswitch(config)# ip default-gateway 10.10.0.1
can be used as alternative. This means that all traffic regarding subnets the switch doesn't know will be send to the router router(config)#ip route 10.10.1.0 255.255.255.0 10.10.0.2
all traffic for the Datacenter will be sent to the Datacenter Switchrouter(config)#ip route 10.10.2.0 255.255.255.0 10.10.0.3
all traffic for the Sales Department will be sent to the Sales Switchrouter(config)#ip route 10.10.3.0 255.255.255.0 10.10.0.4
all traffic for the Marketing Department will be sent to the Marketing Switch. salesswitch(config)# ip access-list extended "ACL_TRANSFER_TO_ROUTER"
salesswitch(config-ext-nacl)# 10 permit tcp 10.10.2.0 0.0.0.255 10.10.1.100 0.0.0.0 eq 445
salesswitch(config-ext-nacl)# 20 deny ip 10.10.2.0 0.0.0.255 10.10.1.100 0.0.0.0
hostname "Switch1"
time timezone 60
time daylight-time-rule Western-Europe
console inactivity-timer 60
ip access-list extended "Transfer_to_DC_ACL"
10 deny tcp 10.10.0.0 0.0.0.255 10.10.100.0 0.0.0.255 eq 3389
20 permit ip 10.10.0.0 0.0.0.255 10.10.100.0 0.0.0.255
30 permit ip 10.10.0.0 0.0.0.255 10.10.150.0 0.0.31.255
40 deny ip 10.10.0.0 0.0.0.255 10.10.200.0 0.0.0.15
50 deny ip 10.10.0.0 0.0.0.255 10.10.201.0 0.0.0.255
60 deny ip 10.10.0.0 0.0.0.255 10.10.202.0 0.0.0.255
70 deny ip 10.10.0.0 0.0.0.255 10.10.203.0 0.0.0.255
80 deny tcp 10.10.0.0 0.0.0.255 10.10.204.0 0.0.0.255 eq 3389
90 permit ip 10.10.0.0 0.0.0.255 10.10.204.0 0.0.0.255
200 deny tcp 10.10.1.0 0.0.0.255 10.10.100.0 0.0.0.255 eq 3389
210 permit ip 10.10.1.0 0.0.0.255 10.10.100.0 0.0.0.255
220 permit ip 10.10.1.0 0.0.0.255 10.10.150.0 0.0.31.255
230 deny ip 10.10.1.0 0.0.0.255 10.10.200.0 0.0.0.15
240 deny ip 10.10.1.0 0.0.0.255 10.10.201.0 0.0.0.255
250 permit ip 10.10.1.0 0.0.0.255 10.10.202.0 0.0.0.255
260 deny ip 10.10.1.0 0.0.0.255 10.10.203.0 0.0.0.255
270 deny ip 10.10.1.0 0.0.0.255 10.10.204.0 0.0.0.255
300 deny tcp 10.10.2.0 0.0.0.255 10.10.100.0 0.0.0.255 eq 3389
310 permit ip 10.10.2.0 0.0.0.255 10.10.100.0 0.0.0.255
320 permit ip 10.10.2.0 0.0.0.255 10.10.150.0 0.0.31.255
330 deny ip 10.10.2.0 0.0.0.255 10.10.200.0 0.0.0.15
340 deny ip 10.10.2.0 0.0.0.255 10.10.201.0 0.0.0.255
350 deny ip 10.10.2.0 0.0.0.255 10.10.202.0 0.0.0.255
360 deny ip 10.10.2.0 0.0.0.255 10.10.203.0 0.0.0.255
370 permit ip 10.10.2.0 0.0.0.255 10.10.204.0 0.0.0.255
400 deny tcp 10.10.3.0 0.0.0.255 10.10.100.0 0.0.0.255 eq 3389
410 permit ip 10.10.3.0 0.0.0.255 10.10.100.0 0.0.0.255
420 permit ip 10.10.3.0 0.0.0.255 10.10.150.0 0.0.31.255
430 permit ip 10.10.3.0 0.0.0.255 10.10.200.0 0.0.0.15
440 permit ip 10.10.3.0 0.0.0.255 10.10.201.0 0.0.0.255
450 permit ip 10.10.3.0 0.0.0.255 10.10.202.0 0.0.0.255
460 permit ip 10.10.3.0 0.0.0.255 10.10.203.0 0.0.0.255
470 permit ip 10.10.3.0 0.0.0.255 10.10.204.0 0.0.0.255
500 permit ip 10.10.4.0 0.0.0.255 10.132.72.240 0.0.0.0
510 deny ip 10.10.4.0 0.0.0.255 10.10.100.0 0.0.0.255
520 deny ip 10.10.4.0 0.0.0.255 10.10.150.0 0.0.31.255
530 deny ip 10.10.4.0 0.0.0.255 10.10.200.0 0.0.0.15
540 deny ip 10.10.4.0 0.0.0.255 10.10.201.0 0.0.0.255
550 deny ip 10.10.4.0 0.0.0.255 10.10.202.0 0.0.0.255
560 deny ip 10.10.4.0 0.0.0.255 10.10.203.0 0.0.0.255
570 deny ip 10.10.4.0 0.0.0.255 10.10.204.0 0.0.0.255
600 permit ip 10.10.7.0 0.0.0.15 10.10.100.0 0.0.0.255
610 permit ip 10.10.7.0 0.0.0.15 10.10.150.0 0.0.31.255
620 permit ip 10.10.7.0 0.0.0.15 10.10.200.0 0.0.0.15
630 permit ip 10.10.7.0 0.0.0.15 10.10.201.0 0.0.0.255
640 permit ip 10.10.7.0 0.0.0.15 10.10.202.0 0.0.0.255
650 permit ip 10.10.7.0 0.0.0.15 10.10.203.0 0.0.0.255
660 permit ip 10.10.7.0 0.0.0.15 10.10.204.0 0.0.0.255
700 deny ip 10.10.0.0 0.0.7.255 10.128.0.0 0.7.255.255
710 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
exit
module 1 type J86xxA
interface 1
name "Connection_to_DC"
speed-duplex auto-1000
exit
interface 2
name "WAN_Optimizer"
speed-duplex auto-1000
exit
interface 3
name "3 Printer1"
exit
interface 4
name "4 Printer2"
exit
interface 6
name "6 Client1"
exit
interface 7
name "Client2"
exit
interface 8
name "8 Client3"
exit
interface 9
name "9 Client 4"
exit
interface 13
name "13 Printer3"
exit
interface 15
name "UPL_Switch4_1"
speed-duplex auto-1000
exit
interface 16
name "UPL_Switch4_2"
speed-duplex auto-1000
exit
interface 17
name "UPL_Switch3_1"
speed-duplex auto-1000
exit
interface 18
name "UPL_Switch3_2"
speed-duplex auto-1000
exit
interface 19
name "UPL_Switch2_1"
speed-duplex auto-1000
exit
interface 20
name "UPL_Switch2_2"
speed-duplex auto-1000
exit
interface 23
name "Client5"
exit
trunk 19-20 Trk1 LACP
trunk 17-18 Trk2 LACP
trunk 15-16 Trk3 LACP
ip routing
snmpv3 enable
snmpv3 group ManagerAuth user "UserName" sec-model ver3
vlan 1
name "DEFAULT_VLAN"
untagged Trk1-Trk3
ip address dhcp-bootp
no untagged 1-14,21-24
exit
vlan 760
name "CLIENTNET"
untagged 3,5-6,8-9,11-12,14,21-24
ip helper-address 10.132.72.13
ip address 10.10.0.1 255.255.255.0
tagged Trk1-Trk3
exit
vlan 770
name "SERVERNET"
untagged 7,10
ip address 10.10.1.1 255.255.255.0
tagged Trk1-Trk3
exit
vlan 780
name "PRINTERNET"
untagged 4,13
ip helper-address 10.132.72.13
ip address 10.10.2.1 255.255.255.0
tagged Trk1-Trk3
exit
vlan 790
name "MGMTNET"
untagged 2
ip address 10.10.3.1 255.255.255.0
tagged Trk1-Trk3
exit
vlan 800
name "GUESTNET"
ip address 10.10.4.1 255.255.255.0
tagged Trk1-Trk3
exit
vlan 830
name "TRANSFERNET"
untagged 1
ip address 10.10.7.5 255.255.255.240
tagged Trk1-Trk3
ip access-group "Transfer_to_DC_ACL" out
exit
fault-finder bad-driver sensitivity high
fault-finder bad-transceiver sensitivity high
fault-finder bad-cable sensitivity high
fault-finder too-long-cable sensitivity high
fault-finder over-bandwidth sensitivity high
fault-finder broadcast-storm sensitivity high
fault-finder loss-of-link sensitivity high
fault-finder duplex-mismatch-hdx sensitivity high
fault-finder duplex-mismatch-fdx sensitivity high
fault-finder link-flap sensitivity high
banner motd "\"Authorized access only!\n\nDisconnect IMMEDIATELY if you are not
an\n authorized user!\""
radius-server host 10.10.202.100 key "RADIUSSERVERKEY"
timesync sntp
sntp unicast
sntp server priority 1 10.10.201.5 4
no telnet-server
no web-management
ip authorized-managers 10.10.150.0 255.255.224.0 access manager
ip authorized-managers 10.10.100.0 255.255.255.0 access manager
ip authorized-managers 10.10.3.0 255.255.255.0 access manager
ip authorized-managers 10.10.201.0 255.255.255.0 access manager
ip dns domain-name "Domain.local"
ip dns server-address priority 1 10.10.203.5
ip dns server-address priority 2 10.10.203.6
ip route 10.10.150.0 255.255.224.0 10.10.7.3
ip route 10.10.100.0 255.255.255.0 10.10.7.3
ip route 10.10.201.0 255.255.255.0 10.10.7.3
ip route 10.10.202.0 255.255.255.0 10.10.7.3
ip route 10.10.200.0 255.255.255.248 10.10.7.3
ip route 10.10.203.0 255.255.255.0 10.10.7.3
ip route 10.10.204.0 255.255.255.128 10.10.7.3
router vrrp
snmp-server community "Community" operator
snmp-server contact "Admins" location "DC"
snmpv3 user "Username"
aaa accounting network start-stop radius
aaa authentication port-access eap-radius authorized
aaa authentication mac-based chap-radius authorized
aaa port-access authenticator active
aaa port-access mac-based 3-6,11-14,21-24
aaa port-access mac-based 3 unauth-vid 800
aaa port-access mac-based 4 logoff-period 10080
aaa port-access mac-based 4 unauth-vid 800
aaa port-access mac-based 5 unauth-vid 800
aaa port-access mac-based 6 unauth-vid 800
aaa port-access mac-based 8 unauth-vid 800
aaa port-access mac-based 9 unauth-vid 800
aaa port-access mac-based 11 unauth-vid 800
aaa port-access mac-based 12 unauth-vid 800
aaa port-access mac-based 13 logoff-period 10080
aaa port-access mac-based 13 unauth-vid 800
aaa port-access mac-based 14 unauth-vid 800
aaa port-access mac-based 21 unauth-vid 800
aaa port-access mac-based 22 unauth-vid 800
aaa port-access mac-based 23 unauth-vid 800
aaa port-access mac-based 24 unauth-vid 800
aaa port-access mac-based addr-format single-dash
spanning-tree
spanning-tree 3 bpdu-protection
spanning-tree 4 bpdu-protection
spanning-tree 5 bpdu-protection
spanning-tree 6 bpdu-protection
spanning-tree 7 bpdu-protection
spanning-tree 8 bpdu-protection
spanning-tree 9 bpdu-protection
spanning-tree 10 bpdu-protection
spanning-tree 11 bpdu-protection
spanning-tree 12 bpdu-protection
spanning-tree 13 bpdu-protection
spanning-tree 14 bpdu-protection
spanning-tree Trk1 priority 4
spanning-tree Trk2 priority 4
spanning-tree Trk3 priority 4
spanning-tree priority 1 force-version rstp-operation
vlan 760
vrrp vrid 41
owner
virtual-ip-address 10.10.0.1 255.255.255.0
priority 255
enable
exit
exit
vlan 770
vrrp vrid 42
owner
virtual-ip-address 10.10.1.1 255.255.255.0
priority 255
enable
exit
exit
vlan 780
vrrp vrid 43
owner
virtual-ip-address 10.10.2.1 255.255.255.0
priority 255
enable
exit
exit
vlan 790
vrrp vrid 44
owner
virtual-ip-address 10.10.3.1 255.255.255.0
priority 255
enable
exit
exit
vlan 800
vrrp vrid 46
owner
virtual-ip-address 10.10.4.1 255.255.255.0
priority 255
enable
exit
exit
vlan 830
vrrp vrid 49
owner
virtual-ip-address 10.10.7.5 255.255.255.240
priority 255
enable
exit
exit
no autorun
no dhcp config-file-update
no dhcp image-file-update
password manager
password operator